Readable, Succinct, or Just Plain Short?

See the original posting on DZone Python

Which is more readable?releaseVersion = version.substring(0, version.indexOf(‘-SNAPSHOT’))

orreleaseVersion = version[0..-10]

Given a value of 0.109-SNAPSHOT for version, they both give the same result. And I’m tempted by the second, because it’s shorter. But I’m going to go with the first one – not because it’s more Java-ish and I’m scared of Groovy syntax, but because it’s…